PDA

View Full Version : Full cycle but limp trigger


phalpin
June 15, 2002, 15:22
I have built a G-1 on an Imbel recvr.
Finally got it to cycle properly and now I have another problem.
Rifle cycles fine, extracting and feeding o.k.
The problem is the trigger is not reset afterwards.
The safety selector is stiff after every shot, but once I wiggle it to safe and back to fire the trigger is set and will fire.
I'm not sure where to start.
Any suggestions??

Thanks
Paul

W.E.G.
June 15, 2002, 18:25
Who made the hammer/trigger/sear?

jim
June 16, 2002, 01:33
good chance it is weak springs.
this causes your trigger to not go foward all the way (resetting)

1006587
June 16, 2002, 08:10
Century parts? Could be a bad hammer. The slot for the hammer spring is too low and doesn't have enough leverage to reset the hammer. No way to salvage, buy FSE or DSA.

Is the plunger on the sear spring? Just check don't ask how I know.

phalpin
June 16, 2002, 11:06
Everything is original.
I'm still trying to get a fully functional rifle before I start
replacing parts to be legal.
Sounds like I should go ahead with the HTS replacement.

W.E.G.
June 16, 2002, 14:31
Realistically (and legally) you are probably going to need to replace the h/t/s anyway. DSA is probably the "best" (and most expensive). FSE is good enough (and a lot cheaper).

Master Blaster
June 17, 2002, 18:37
I have had this problem in the past and for me it was easily corrected by making sure that the trigger return plunger and spring were no binding in the pistol grip.

Try opening up and smoothing the hole in the PG where the plunger passes through just a little bit. Look into the pistol grip from the front where the Plate is screwed in place you will see the hole that I am referring to.

It can often be corrected by making sure that the retaining plate that holds' the plunger in place is not binding the return movement. HTH!
Regards,
Jim