PDA

View Full Version : Browning Hi-Power Forum?


kar66
January 16, 2015, 10:20
What happened to the Browning Hi-Power Owner's Forum-BHP Talk? I think I learned about it on this forum. Did they change their name, shut down or what? I didn't use a lot but they knew more about Hi-Powers than most other forums and answered most of my Hi-Power questions. I think I learned about them on this forum. I am sure there are other just as good Hi-Power forums. But I was happy with them and would like to find them again. Thanks :confused:

homelandprotector
January 16, 2015, 13:48
You sort of just posted in it....look under the 1911 Files title on the forum front page it says......

The All-Time Classic Combat Handgun - 1911 and Browning High Power Discussion

Just gota read the fine print. :wink:

metalreptile
January 17, 2015, 20:45
http://hipowerforum.com/index.php?sid=9c3b906a4d19f8b6455e45662777d905

kar66
January 17, 2015, 22:35
Thanks Metalreptile I will give them a try. Some of the names look the same.

metalreptile
January 22, 2015, 21:45
Thanks Metalreptile I will give them a try. Some of the names look the same.

No problem.....it's the same forum you were looking for.....they changed to this one for some reason, still not sure why. The old one is gone.

raexcct2
January 22, 2015, 23:19
I was a member on the old forum but I guess the old registration didn't transfer over to the new forum.

Andy the Aussie
January 23, 2015, 03:25
I was a member on the old forum but I guess the old registration didn't transfer over to the new forum. .... same here mate.

kar66
January 23, 2015, 09:46
No I guess it didn't. I don't think I missed very many days being on it, then one day it was just gone. At the time I was having problems with my computer and wasn't sure that wasn't the problem. Another forum that I go to was also having some problems. But you could still get on it. It was just in another style and didn't seem right, but they are back up like they were before now. Back to the Hi-Power forum I recognize a lot of the old names, but there seems to be some missing. But anyway it is good to have it back. I just wish they had give some notification of what had happened. I guess it happens more than we think. I know that is the way it was with the old G43 forum too.

lostmybearing
January 23, 2015, 10:47
I am still waiting for them to activate my membership. Same user name and eveything. I guess I'll have to try again.

I just tried from work and my company is blocking access due to trier URL being "uncatagorized" . :cry:

kar66
January 23, 2015, 14:26
I think it was the next day before mine was approved.

metalreptile
January 23, 2015, 21:57
http://hipowerforum.com/viewtopic.php?f=2&t=4