PDA

View Full Version : Trigger group ejecting


Trooper894
April 23, 2008, 22:22
Customer brought in a well used 3,000,000+ SA Garand in a new "fat" walnut stock, (unsure if it is a Boyd's stock), stating that the trigger group kept "ejecting" from the rifle when fired. I don't recall if he stated the trigger guard was still latched after each "ejection". I checked the tension on the stamped trigger guard, it was a little loose but not by a great deal, adjusted it up a little tighter. Checked the lugs on the trigger guard and they were slightly flattened but not very badly. However the trigger guard is very loose on the trigger housing. I don't know at this point whether the holes in the guard are oversized, or the lugs on the trigger housing are worn. Am I missing something else that I should look at for him?
I appologize in advance for missing some important clues here but any trouble shooting points to check would be appreciated.

Seaweed
April 24, 2008, 12:02
A little loose is all it takes. Try to shim tight the trigger group, and try again. Or try another trigger group w/o wear on the lugs. I have had the same problem, tightening the trigger group to snug is the onlt solution.

Jim

ltcboy
April 30, 2008, 00:01
It's the stock dude. Boyd's havebeen known to keep too much meat on the bone and I have heard of that exact same thing happening. Tyr dropping it into a USGI stock and see what happens.

Mike

fry
April 30, 2008, 13:02
sounds like the trigger group is in way too tight. description of the stock.
i had a brand new nm gun from s/a that was bedded and doing the same thing.
ejecting the trigger group during rapid fire strings.
sent it back and they removed some of the bedding and all was good.
i would have done it myself but is was a new rifle.