PDA

View Full Version : having a problem with top covers


chunster
April 08, 2002, 22:42
I am new to this and I am almost finished building a Fal G1 on an Imbel receiver. I am having a hard time getting the top cover to fit. I bought two used ones and both leave a gap on the front left (the curved side) and sometimes the bolt sticks. What should I do? :confused:

[ April 08, 2002: Message edited by: chunster ]

blackbird
April 09, 2002, 01:07
Press it left at the front as you push in the very last bit. Should catch the shoulder then.

Randall
April 09, 2002, 13:49
I've had the same problem sans the fouling of the bolt. What type of receiver do you have? Mine is a non-gear logo'd Imbel. After trying several dust covers, and ruining one with a dremel, I accepted the fact that I just have a slightly out of spec receiver. There is about a 1/32" gap on that side. No harm no FAL, err...foul. The rifle works just fine. Randy

[ April 09, 2002: Message edited by: Randall ]

JoeLad
April 10, 2002, 16:00
Originally posted by Randall:
<STRONG>I've had the same problem sans the fouling of the bolt. What type of receiver do you have? Mine is a non-gear logo'd Imbel. </STRONG>

Randall,

I have the same problem on my thumbhole CIA L1A1. A small gap on the left front of the cover. I thought it was the cover until the G1, and Imbel covers showed a gap too.

I tried forcing the top of the cover into the groove in the reciver, but then realized if I did get it to fit, it would be hell to get back off again.

The receiver is a no logo Imbel.

Firejunkie :D

[ April 10, 2002: Message edited by: Firejunkie ]

chunster
April 14, 2002, 23:07
I have a new logo Imbel. I solved the problem by getting a new metric top cover and the gap is gone. ;) :D